Symptoms

When a user launches a Test Case or Test Set execution, the page fails to load and displays the following generic UI error:

"There was an error processing the page. Please return to the Home Page."

Upon checking the System Event Log (Administration > System > System Event Log) at the exact time of the failure, you will see Error level events containing the following messages:
- Null returned from CustomLists
- Object reference not set to an instance of an object

If you inspect the full stack trace of the object reference error, it will typically point to the something similar to this:

In PageLayout:: OnError:Messages:Object reference not set to an instance of an object. 
Stack Trace:
at APPLICATION.Web.Classes.ArtifactCustomPropertyInjector.CreateControls(...)
at APPLICATION.Web.TestCaseExecution.LoadAndBindFirstPage()
at APPLICATION.Web.TestCaseExecution.Page_Load(Object sender, EventArgs e)

Root Cause

This error is caused by a data integrity issue related to Test Run Custom Properties.

Specifically, the system is attempting to load the custom properties required for the Test Run execution page, but encounters an "orphaned" list property. This happens when an active Custom Property (configured as a List or Multi-Select List) is pointing to a Custom Property List (CUSTOM_PROPERTY_LIST_ID) that is either inactive, deleted, or missing from the database entirely.

Note: This data discrepancy can sometimes occur due to missing Foreign Key constraints in the database, legacy template migrations, or manual backend database modifications.


Resolution

To fix this issue, you must identify the orphaned custom properties and either disable them or link them to a valid, active list.
 

Step 1: Identify the "Orphaned" Properties from database

If you have a database access, you can run the following SQL query to immediately identify which active custom properties are pointing to missing or inactive lists.

Here is the ESQL query, that applies to both - on-prem and cloud customers. You can run it from the Spira reporting module, with no need to directly access the database:

SELECT P.CUSTOM_PROPERTY_ID, 
       P.Name, 
       P.CUSTOM_PROPERTY_TYPE_ID, 
       P.CUSTOM_PROPERTY_LIST_ID, 
       P.ARTIFACT_TYPE_ID
FROM SpiraTestEntities6.R_CustomPropertyDefinitions AS P
WHERE P.IS_DELETED = false
  AND P.CUSTOM_PROPERTY_TYPE_ID IN {6, 7}
  AND P.CUSTOM_PROPERTY_LIST_ID NOT IN (
      SELECT VALUE L.CUSTOM_PROPERTY_LIST_ID
      FROM SpiraTestEntities6.R_CustomLists AS L 
      WHERE L.Is_Active = true
  )

If you're using Spira installed on-premise and have an access to the database through Management Studio, then the query will be slightly different:

SELECT * FROM TST_CUSTOM_PROPERTY
WHERE IS_DELETED = 0
AND CUSTOM_PROPERTY_TYPE_ID IN (6,7)
AND CUSTOM_PROPERTY_LIST_ID NOT IN (SELECT CUSTOM_PROPERTY_LIST_ID FROM TST_CUSTOM_PROPERTY_LIST WHERE IS_ACTIVE = 1)

 

Step 2: Correct the Configuration in the UI

Once the problematic custom properties are identified follow steps:

  1. Log in to Spira as a System Administrator.

  2. Navigate to Administration > Testing > Test Runs > Custom Properties.

  3. Locate the custom properties identified in the SQL script.

  4. Take one of the following actions:

    • Reassign the List: Edit the custom property and assign it to a valid, active Custom List.

    • Delete/Deactivate: If the custom property is no longer needed, delete it to remove it from the execution page injector.

Once the orphaned properties are resolved, users will be able to launch and execute Test Cases and Test Sets without encountering the "Home Page" error.

If you're still experiencing issues, then please contact support directly in a dedicated ticket.